Jump to content


Resource Links in User Tool Keeps Getting Corrupted

User Tools Links error message

  • Please log in to reply
1 reply to this topic

#1 John Tadlock

John Tadlock


  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Sunnyvale, TX
  • Interests:Discourse analysis; Chronology
  • Accordance Version:11.x

Posted 11 May 2016 - 03:29 PM

Note: I found similar concerns expressed in past posts in this forum, sometimes with a remark that the problem was resolved in version 11.1.4. But I am still experiencing the problem in my version 11.1.6.


I am authoring a fairly long user tool with lots of internal links to other titles within the same user tool. And there are also several links to other resources. I recently started replacing the old format links (like "[BDB, Entry, twldwt]") with the newly formatted links where you select the link type, the resource, the field, the search string, and the display all in a dialog box. (Pretty cool.)


​My problem is that my resource links seems to get corrupted easily. All of them. I am not sure why or how. When editing my user tool I get all the links in a block to save. They work for a while (a few minutes or hours). And then they stop working often with an error message of "The characters in this hyperlink are invalid or ambiguous" or a comment that the resource isn't loaded or a comment that the resource name contains too many characters.


I then have to go into the user tool and recreate the links. Often most if not all of them. It seems that the resource names are corrupted with lots of additional symbol characters. Or the resource name is truncated. The Search field is typically blank. Trying to save (by hitting the "Update" button) fails until I have replaced all the corrupted resource links in the current block.  I will get an error message for the next corrupted resource link each time I try to save. (I am keeping the block size small to minimize the amount of work before I can save again.)


Once successfully saved the links work, for a while, and then get corrupted again.


I can't figure out what event is triggering the corruption. Perhaps quitting and restarting Accordance? I am syncing my user tools with Drop Box. Perhaps Drop Box sync triggers it? And I am using several devices: my desktop mac (running 10.11.4), my older Powerbook running 10.6.8, and an iPad and an iPhone (both up-to-date). The corruption problem will occur even when staying only on my desktop mac. I don't have to switch devices to see it happen.


P.S. Another issue I ran into when recently updating my links is that many of my long-standing scripture reference links had to also get rebuilt because of a following punctuation mark ("." or ":" for example) causing an error message when saving. I have been working on this user tool for many years. So it was a surprise that scripture reference links that worked for a long time suddenly started to have errors.


P.S.S. Long term I would like to see Accordance supporting authoring more. Right now Accordance seems to mostly support note taking and not larger scale authoring. But having access to resources via links is so useful that authoring outside of Accordance itself means losing some very powerful tools. It would be super to be able to publish a user tool to a website and have the links all still work even without the Accordance application. (Perhaps some sort of subscription to online Accordance resources might be needed.)




John Tadlock

#2 Joel Brown

Joel Brown


  • Admin
  • 6,460 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:13.x
  • Platforms:Mac OS X, Windows, iOS

Posted 11 May 2016 - 06:41 PM

John, we definitely fixed a variety of issues in 11.1.5 and 11.1.6, but it is possible that we missed a case.  If you could help me with two things, we can narrow this down:


1) How are you sending the user tool to other devices?  Via dropbox?  If so, if you turn off Dropbox Syncing or set it to Manual (and don't sync), do you still get the issue?


2) If you can recall any sort of semi-consistent case in which the links get corrupt, it would be extremely helpful.  Perhaps try saving very regularly, and then the moment it complains about an invalid link, recall the most recent action or two.




Joel Brown

By day: Lead Software Engineer at Accordance
By night: Freelance Trombonist

Also tagged with one or more of these keywords: User Tools, Links, error message

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users