Jump to content


Photo

Copy as a Citation BUG


  • Please log in to reply
9 replies to this topic

#1 miketisdell

miketisdell

    Silver

  • Active Members
  • PipPipPip
  • 190 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 16 July 2018 - 12:27 AM

When I copy and paste Hebrew text as a citation I am experiencing several bugs.

 

1) There are numerous spaces added between the letters of various words. See "אֲשֶׁ֤֣ר", "מִתַָּ֑֜חַת", "אֲשֶׁ֥֣ר", "בַּמַּ֖֣יִם", etc... from the verse below.

 

2) Justification is almost always left to right instead of right to left (a little easier to correct than the space issue.

 

”‏וַיְדַבֵּ֣ר אֱלֹהִ֔ים אֵ֛ת כָּל־הַדְּבָרִ֥ים הָאֵ֖לֶּה לֵאמֹֽר׃ ס‎ ‏אָֽנֹכִ֖י֙ יְהוָ֣ה אֱלֹהֶ֑֔יךָ אֲשֶׁ֧ר הוֹצֵאתִ֛יךָ מֵאֶ֥רֶץ מִצְרַ֖יִם מִבֵּ֣֥ית עֲבָדִֽ֑ים׃‎ ‏לֹֽ֣א יִהְיֶֽה־לְךָ֛֩ אֱלֹהִ֥֨ים אֲחֵרִ֖֜ים עַל־פָּנָֽ֗יַ‎ ‏לֹֽ֣א תַֽעֲשֶׂ֨ה־לְךָ֥֣ פֶ֣֙סֶל֙ ׀ וְכָל־תְּמוּנָ֡֔ה אֲשֶׁ֤֣ר בַּשָּׁמַ֣֙יִם֙ ׀ מִמַּ֡֔עַל וַֽאֲשֶׁ֥ר֩ בָּאָ֖֨רֶץ מִתַָּ֑֜חַת וַאֲשֶׁ֥֣ר בַּמַּ֖֣יִם ׀ מִתַּ֥֣חַת לָאָֽ֗רֶץ‎ ‏לֹֽא־תִשְׁתַּחְוֶ֥֣ה לָהֶ֖ם֮ וְלֹ֣א תָעָבְדֵ֑ם֒ כִּ֣י אָֽנֹכִ֞י יְהוָ֤ה אֱלֹהֶ֙יךָ֙ אֵ֣ל קַנָּ֔א פֹּ֠קֵד עֲוֹ֨ן אָבֹ֧ת עַל־בָּנִ֛ים עַל־שִׁלֵּשִׁ֥ים וְעַל־רִבֵּעִ֖ים לְשֹׂנְאָֽ֑י“
(Exodus 20:1-5 Hebrew Masoretic Text with Westminster Hebrew Morphology)



#2 miketisdell

miketisdell

    Silver

  • Active Members
  • PipPipPip
  • 190 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 17 July 2018 - 02:42 PM

Is this on someone's radar to get fixed?



#3 Helen Brown

Helen Brown

    Emerald

  • Admin
  • 11,389 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:12.x
  • Platforms:Mac OS X, Windows, iOS, Android

Posted 17 July 2018 - 07:39 PM

The development team do take note of all bug reports, but they only comment if further clarification is needed. So yes, this is on "someone's radar" but we cannot promise a date for a fix, if one is needed and possible.

 

In this case I do not see extra spaces in the above citation. Where were you pasting it? I do suggest stripping the cantillation marks unless you really need them, as they may not be properly supported in the receiving app.


Helen Brown
OakTree Software

#4 miketisdell

miketisdell

    Silver

  • Active Members
  • PipPipPip
  • 190 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 17 July 2018 - 11:14 PM

The development team do take note of all bug reports, but they only comment if further clarification is needed. So yes, this is on "someone's radar" but we cannot promise a date for a fix, if one is needed and possible.

 

In this case I do not see extra spaces in the above citation. Where were you pasting it? I do suggest stripping the cantillation marks unless you really need them, as they may not be properly supported in the receiving app.

 

Helen,

 

The spaces are there. I can see them both in this post and in MS Word (which does support cantillation marks). In my word document I deleted all of the spaces that did not belong there and the text was fine; however, this is a tedious process for longer texts and error prone.

The four words I posted in the example above were copied from the text below and all have a space that doesn't belong there. I will place the same examples here with a few extra added spaces to make it more clear where the improper spacing is in the text:

 

"אֲשֶׁ֤֣    ר"  , "מִתַָּ֑֜    חַת"  , "אֲשֶׁ֥֣    ר"   , "בַּמַּ֖֣    יִם"

 

I tried a regular cut and past and see the the text is correctly right justified, but the spaces still appear in the text. I had thought the problem only existed in copy as a citation, but think I must have just missed it when the text looked more normal. Now I need to go back and check my work.

 

P.S. If there is an easy way to strip out the cantillation marks and or nekkud, I would be very happy to know how to do that. This is one of the feature requests I made earlier. In Bibleworks, I can toggle the nekkud on and off with a single button, but I don't know of any thing like that in Accordance.



#5 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 5,337 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:12.x
  • Platforms:Mac OS X, Windows

Posted 18 July 2018 - 10:54 AM

Mike, I believe the problem is that you are trying to render with a font that does not have those cantillation characters. What font are you rendering with?

 

If you wish to export the characters without cantillation, this is an option in Preferences -> Export -> Hebrew Export -> Strip Characters.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#6 Ken Simpson

Ken Simpson

    Mithril

  • Accordance
  • 2,456 posts
  • Gender:Male
  • Location:Sydney, Australia
  • Interests:My grandsons Micah and Nate!
    Astronomy
    Archaeology
    Physics
    Hebrew and Greek
    Papyrology
    Orthopædic Surgery
  • Accordance Version:12.x
  • Platforms:Mac OS X, Windows, iOS

Posted 18 July 2018 - 06:03 PM

Hey Mike, I must admit when I looked at your paste above, it looked fine to me. Just didn't get around to comment. Plus, I wasn't sure what to say when I couldn't see the issue myself. Fonts are black magic sometimes.

 

So you can see what we are seeing...

 

Attached File  Screen Shot 2018-07-19 at 09.09.41 .jpg   31.56KB   0 downloads


  • miketisdell likes this
Regards
Ken
Lead Australian Accordance Demonstrator
Administrator, Accordance Exchange
Assistant Minister, Summer Hill Church

#7 miketisdell

miketisdell

    Silver

  • Active Members
  • PipPipPip
  • 190 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 18 July 2018 - 06:36 PM

Mike, I believe the problem is that you are trying to render with a font that does not have those cantillation characters. What font are you rendering with?

 

If you wish to export the characters without cantillation, this is an option in Preferences -> Export -> Hebrew Export -> Strip Characters.

 

 

It was the font but with a catch. I usually use SBL Hebrew as my font which works fine in Word. When I am setup for SBL and copy and paste from Bibleworks, the font is maintained. However, if I copy and past from Accordance the font in the pasted text is changed to Times Roman (which creates the issue). Could we make sure that Accordance either leaves the font at the default or chooses SBL Hebrew by default so that this issue goes away?

 

Note: It does make it a lot easier to correct, now that I know what is happening.



#8 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 5,337 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:12.x
  • Platforms:Mac OS X, Windows

Posted 18 July 2018 - 06:39 PM

Mike, check your Preferences -> Export -> Use Default Font checkbox.  I believe if you turn that off it should retain the source font.  Alternatively, you could specify a better font.  Finally, in the Preferences -> Unicode Display, if you specify a nice set of language specific unicode fonts, you can use the "Use these fonts for Unicode export" to specify the perfect font for each language.


  • miketisdell likes this
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#9 Michel Gilbert

Michel Gilbert

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,096 posts
  • Gender:Male
  • Location:Monet
  • Interests:heritage homes, antiques, gardens, fresh food, good coffee, live music, ויין אשר ישמח לבב אנוש (Ps 104,15)
  • Accordance Version:12.x
  • Platforms:Mac OS X, Windows, iOS, Android

Posted 18 July 2018 - 08:24 PM

Mike,

 
I'm not the biggest fan of Word, but we all have to use in in our field. I offer this in case it will help. 
 
Here is the cantillation in Word for Mac, Version 16:15. 
 
Attached File  Cantillation in Word.png   658.36KB   0 downloads
 
You can also enter any Unicode character for any language. Which version of Word are you using?
 
Also, if you Copy or Copy As Citation from Acc into Word, the Hebrew order will be incorrect, as in your example, and in mine in the screenshot. If you select what you pasted and set it to rtl direction and right justify, it to will be in the correct order properly justified.
 
Really support you on the need for right justification. Rick M. gave a hint that it may be in the works.
 
Regards,
 
Michel
 

Michel G. Distefano, Ph.D.

 

Accordance Desktop 12.3 beta on Mac mini, Mojave, 10.14

Accordance iOS 2.7.2 on iPad mini
Accordance Android 1.2.1 on Huawei 6.0.1

  


#10 miketisdell

miketisdell

    Silver

  • Active Members
  • PipPipPip
  • 190 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 19 July 2018 - 09:59 AM

Mike, check your Preferences -> Export -> Use Default Font checkbox.  I believe if you turn that off it should retain the source font.  Alternatively, you could specify a better font.  Finally, in the Preferences -> Unicode Display, if you specify a nice set of language specific unicode fonts, you can use the "Use these fonts for Unicode export" to specify the perfect font for each language.

 

 

That works, thanks!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users