Jump to content


Photo

Troubleshooting basic Hebrew construct searches


  • Please log in to reply
1 reply to this topic

#1 mbl

mbl

    Member

  • Members
  • Pip
  • 1 posts
  • Accordance Version:12.x
  • Platforms:Windows, Android

Posted 15 October 2019 - 03:32 PM

Hi,

 
I'm new to the HMT Syntax module and have been working through the Brief User's Guide.  However, other the first sample search (sec 5.1 null predicate clause), I have not been able to reproduce the results in the guide either by building the construct searches myself or using the downloadable workspaces (from https://www.accordan.../Documentation/).  I have tried this with several searches--for example, the image below (Fig 1) is from sec 5.3 .  The only change I made to the original workspace was to limit the range to Genesis, which would still allow me to verify the first several results shown in the user's guide.
 
Attached File  Fig1_20191015.png   341.25KB   0 downloads
 
To narrow down the problem, I tried a couple smaller searches to "build up" to the construct search of Sec 5.2 (null predicate without participial complement).  First, I had no problem finding a null predicate within a predicate phrase.  As shown in Fig 2, there were two hits in Gen 1:2, as expected.
 
Attached File  Fig2_20191015.png   442.18KB   0 downloads
 
I also searched within a predicated phrase for a complement phrase without a participial complement.  The results for Gen 1:2 are also what I would have expected (Fig 3)
 
Attached File  Fig3_20191015.png   440.68KB   0 downloads
 
If I tighten up the construct so the depth = 0, the results narrowed, as expected (Fig 4).
 
Attached File  Fig4_20191015.png   440.9KB   0 downloads
 
If I am understanding the constructs correctly, then by combining these two searches  to look for predicate phrases containing both a null predicate and non-participial complement, I should expect the results to include [עַל־פְּנֵ֣י תְה֑וֹם - ] in Gen 1:2, as shown in the figure on p.51 of the guide.  However, I do not get any results in the range (Gen), as shown below (Fig 5).
 
Attached File  Fig5_20191015.png   444.56KB   0 downloads
 
The same thing happens when I run 2-NullCopulaNonParticipialComp.accord directly (again, changing the range to Gen) as in Fig 6.
 
Attached File  Fig6_20191015.png   337.74KB   0 downloads
 
 
I have also tried to reproduce several other construct searches from this forum, with similar lack of success.  (And of course, I've tried the obvious restarting, confirming all modules are up to date, etc.)
 
Any suggestions would be most appreciated.
 
Thanks!
 


#2 Robert Holmstedt

Robert Holmstedt

    Platinum

  • Accordance
  • 859 posts
  • Gender:Male
  • Accordance Version:12.x
  • Platforms:Mac OS X, iOS

Posted 16 October 2019 - 04:10 PM

Ok, I spent over an hour working on the searches. There is definitely something "broken". They searches are *really* slow and there are no hits. This must have happened during some update of Accordance. I'll ask that it's looked into for the coming 13 release.


  • Unix and MattChristian like this
Professor, Hebrew and Northwest Semitic Languages
Dept. of Near and Middle Eastern Civilizations
The University of Toronto
blog: ancienthebrewgrammar.wordpress.com
https://utoronto.aca...RobertHolmstedt




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users