Jump to content


Photo

Imported English Bible text displayed in Helena font


  • Please log in to reply
5 replies to this topic

#1 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 25 posts
  • Accordance Version:8.x

Posted 24 February 2020 - 10:39 AM

I'm using 13.0.4 on MacOS 10.15.3.

 

I have just tried reimporting an old user Bible text (an English translation), and it displays using Helena font. The text file is Mac OS Roman. The Set Text Display dialogue for the imported text has Helena for the font under customise Contents but greyed out. The font cannot be changed.

 

What am I doing wrong? The import used to work fine.

 

Edit: it appears that the Bible text has been imported as a "Greek Text". It is listed under Greek Texts in the Amplify menu.

 

Thanks.


Edited by Andrew Perriman, 24 February 2020 - 10:58 AM.


#2 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 25 posts
  • Accordance Version:8.x

Posted 25 February 2020 - 04:25 AM

Further to this, I have two quite similar versions of the same English translation. Both are Legacy Mac (CR) and Western (Mac OS Roman). One imports as a Greek text with Helena font, the other imports as an English text as expected. Apart from a difference in size, I cannot see any other difference between the two source files. I have tried deleting from the Library, restarting Accordance, and re-importing, but the outcome is the same.



#3 Helen Brown

Helen Brown

    Emerald

  • Admin
  • 12,058 posts
  • Twitter:accordancebible
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:13.x
  • Platforms:Mac OS X, Windows, iOS, Android

Posted 02 March 2020 - 02:28 PM

Have you tried simply setting the display font after import?


Helen Brown
OakTree Software

#4 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 25 posts
  • Accordance Version:8.x

Posted 11 March 2020 - 03:54 AM

Yes. The font option under Customise Theme in the Set Display Text box is greyed out. See attached image.

Attached Files



#5 Fabian

Fabian

    Mithril

  • Super Member
  • PipPipPipPipPipPip
  • 4,525 posts
  • Gender:Not Telling
  • Accordance Version:13.x
  • Platforms:Mac OS X, iOS

Posted 11 March 2020 - 04:39 AM

If the text is imported as a Greek text, then the options are greyed out. 

 

The question is more; why is it imported as a Greek texts? 

 

Try to copy the text from BBEdit to a new file of BBEdit and import it again.

 

Try also to import only a part of this texts. To see what happens. Especially if you import it from the second book of your text.


Edited by Fabian, 11 March 2020 - 04:48 AM.

Greetings

Fabian

ATTENTION: My bug reports are all with the GERMAN INTERFACE and with the EUROPEAN NOTATION! It can be the English interface has no bugs, I describe.

PLEASE!
Bring more international Bibles to the store,
fix my reported bugs, even the old ones which never was addressed,
develop my feature requests, the new once and the once I made years ago,
in nearer future.

#6 Andrew Perriman

Andrew Perriman

    Member

  • Active Members
  • Pip
  • 25 posts
  • Accordance Version:8.x

Posted 11 March 2020 - 05:03 AM

It appears that the bad text file was encoded “UTF8, with BOM”. How that came about, I don't know. I thought I'd checked that. It's now fixed, anyway. Thanks for your help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users