Jump to content


Photo

"Copy as Citation" is removing letters (and spaces) from passages

copy citation missing characters paste

  • Please log in to reply
5 replies to this topic

#1 1029384756

1029384756

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:13.x
  • Platforms:Windows, Android

Posted 17 July 2020 - 03:03 PM

I've seen various posts that mention similar issues, but most were for the Mac version. I'm running Accordance 13.1.2 on Windows 10 x64 (Version 10.0.18363 Build 18363) on a Dell Latitude E6540.

 

If I select, let's say, Mark 1:9 (ESV) and do "Ctrl + Alt + C" to copy as a citation, then paste it... Here is what I get: 

 

“And it me to pass in those days, that Jesus came from Nazareth of Galilee, and was baptized of John in Jordan.” (Mark 1:9)
 
If I just do a "regular" (Ctrl + C) copy, then I get this: 
 
And it came to pass in those days, that Jesus came from Nazareth of Galilee, and was baptized of John in Jordan.
 
Notice that came is truncated to me when copied as a citation. In addition, if copying a larger passage as a citation, the spaces between verses are removed, like so: 
 
“And it me to pass in those days, that Jesus came from Nazareth of Galilee, and was baptized of John in Jordan.And straightway coming up out of the water, he saw the heavens opened, and the Spirit like a dove descending upon him:And there came a voice from heaven, saying, Thou art my beloved Son, in whom I am well pleased.And immediately the Spirit driveth him into the wilderness.And he was there in the wilderness forty days, tempted of Satan; and was with the wild beasts; and the angels ministered unto him.” (Mark 1:9–13)
 
Notice in the passage above that between every verse the period is squished right up against the beginning of the next verse without a space. This is quite problematic, because I have to proofread every citation! I'm hoping there's a simple fix for this. :)
 
I've attached a screenshot showing my preferences panel for "Copy as Citation" as well my text selection that results in the pasted passage above. Thanks!
 

 

 



#2 Silas Marrs

Silas Marrs

    Platinum

  • Accordance
  • 837 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:13.x
  • Platforms:Mac OS X, Windows

Posted 21 July 2020 - 10:05 AM

This doesn't happen when I copy as citation in the same verse in KJVS, on Windows 10.  Can you post a screenshot of your citation preferences so I can see what the difference is?



#3 1029384756

1029384756

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:13.x
  • Platforms:Windows, Android

Posted 21 July 2020 - 04:30 PM

This doesn't happen when I copy as citation in the same verse in KJVS, on Windows 10.  Can you post a screenshot of your citation preferences so I can see what the difference is?

I thought I attached it, but now it's not showing... Let's try again! :)

 

Attached File  accordance.jpg   86.56KB   0 downloads


  • Silas Marrs likes this

#4 1029384756

1029384756

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:13.x
  • Platforms:Windows, Android

Posted 22 July 2020 - 09:38 AM

I tried to reply with a screenshot, but it never came through. Am I not allowed to post attachments? Here's a link to the screenshot: https://www.dropbox....rdance.jpg?dl=0


  • Silas Marrs likes this

#5 Silas Marrs

Silas Marrs

    Platinum

  • Accordance
  • 837 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:13.x
  • Platforms:Mac OS X, Windows

Posted 27 July 2020 - 11:53 AM

Ah, I see the problem.

 

The "Show as:" popup menu in the Contents References section is set to "After Verse", which is incompatible with the "Copy text as one block" preference.

 

Usually, the "one block" option would be greyed out if the "After Verse" option is selected, but it only grays out if you've just selected the value, and not if the dialog opens with this value already selected.

 

I'll fix this in the code.  You should be able to fix this by setting the "Show as:" popup menu in the Contents References section to any non-greyed-out value.



#6 1029384756

1029384756

    Member

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Accordance Version:13.x
  • Platforms:Windows, Android

Posted 28 July 2020 - 02:30 PM

Ah, I see the problem.

 

The "Show as:" popup menu in the Contents References section is set to "After Verse", which is incompatible with the "Copy text as one block" preference.

 

Usually, the "one block" option would be greyed out if the "After Verse" option is selected, but it only grays out if you've just selected the value, and not if the dialog opens with this value already selected.

 

I'll fix this in the code.  You should be able to fix this by setting the "Show as:" popup menu in the Contents References section to any non-greyed-out value.

 

Yes, it looks like that fixed it!! That will be great if it gets fixed in the code so we can't accidentally set options that create problems... :)

Thanks so much for your help! 


  • Silas Marrs likes this





Also tagged with one or more of these keywords: copy, citation, missing, characters, paste

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users