Jump to content


Photo

Accordance Widget in Maverick?

maveric widget

  • Please log in to reply
16 replies to this topic

#1 nikonaddict

nikonaddict

    Member

  • Active Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Zion, IL
  • Interests:Photographing the lands of the Bible
  • Accordance Version:11.x

Posted 25 October 2013 - 09:49 PM

After installing Maverick I am no longer to able to use the "Auto Insert" option in the Accordance Widget. Instead, I get this note: "UI Scripting is not enabled. Please check ‘Enable access for assistance devices’ in the Universal Access pane of System Preferences to enable Auto Search." I was finally able to figure out that this part of the Universal Access pane has been moved to "System Preferences > Security & Privacy > Privacy > Accessibility", but I still can't get the widget to auto insert text? Any suggestions?

 

Attached Files



#2 Helen Brown

Helen Brown

    Mithril

  • Admin
  • 8,500 posts
  • Gender:Female
  • Location:heart in Israel
  • Accordance Version:11.x

Posted 26 October 2013 - 05:59 AM

We are aware of this and looking into a solution.


  • Don Ruhl and Dan Francis like this
Helen Brown
OakTree Software

#3 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,085 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 26 October 2013 - 02:02 PM

Joel,

You can use keystroke within System events without the permissions problem in a Widget's utility script. The problem with the copypaste.scpt in the Widget is that it's accessing the menus with UI scripting. To see what I mean, in that helper script, remove the block that is checking for the presence of a "past and match style" menu item, replacing it just with the keystroke command.

So, remove

tell frontApp to tell menu bar 1
	if (exists menu item "Paste and Match Style" of menu "Edit") then
		click menu item "Paste and Match Style" of menu "Edit"
	else if (exists menu item "Paste" of menu "Edit") then
		click menu item "Paste" of menu "Edit"
	else
		tell application "System Events" to keystroke "v" using {command down}
	end if
end tell

and replace it with

keystroke "v" using {command down}

and the widget's auto pasting works.  You lose the "paste and match style" capability, unfortunately.

You could add an if clause for the most common apps that have the standard key command:

if (name of frontApp) is in {"Word", "Pages", "Keynote"} 
-- whatever apps use ⌘⌥⇧v for match style
keystroke "v" using {command down, shift down, option down}
else
keystroke "v" using {command down}
end

  • Don Ruhl likes this
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#4 Don Ruhl

Don Ruhl

    Member

  • Active Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Grants Pass, Oregon
  • Accordance Version:10.x

Posted 05 November 2013 - 03:20 PM

 

Joel,

You can use keystroke within System events without the permissions problem in a Widget's utility script. The problem with the copypaste.scpt in the Widget is that it's accessing the menus with UI scripting. To see what I mean, in that helper script, remove the block that is checking for the presence of a "past and match style" menu item, replacing it just with the keystroke command.

So, remove

tell frontApp to tell menu bar 1
	if (exists menu item "Paste and Match Style" of menu "Edit") then
		click menu item "Paste and Match Style" of menu "Edit"
	else if (exists menu item "Paste" of menu "Edit") then
		click menu item "Paste" of menu "Edit"
	else
		tell application "System Events" to keystroke "v" using {command down}
	end if
end tell

and replace it with

keystroke "v" using {command down}

and the widget's auto pasting works.  You lose the "paste and match style" capability, unfortunately.

You could add an if clause for the most common apps that have the standard key command:

if (name of frontApp) is in {"Word", "Pages", "Keynote"} 
-- whatever apps use ⌘⌥⇧v for match style
keystroke "v" using {command down, shift down, option down}
else
keystroke "v" using {command down}
end

 

Joe, 

 

So, if I understand you correctly, I can still get the widget to work in the way that you mentioned, that is, without the "Paste and match style," until Accordance finds out how to fix the widget. Is this to be done in Terminal? Can you tell me a little bit more on how to do this? If I open terminal, where do I go from there? Thanks! 

 

Don Ruhl 


Don Ruhl
Church of Christ
220 NE Savage Street
Grants Pass, Oregon 97526-1310
541-476-3100
http://www.GrantsPas...rchofChrist.com
http://www.TheBibleMeditator.com
http://associate.com...aildevotionals/

#5 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,085 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 05 November 2013 - 06:21 PM

Hey, Don,

 

I don't oversee the widget, so was simply offering the fix for improve upon and publish, but I'll offer an easy how to diy.

 

1. Locate the file Accordance.wdgt

It is in ~/Library/Widgets/.  In order to get to the folder, go to Finder, hold down the Option key, and select menu item Go/Library.

 

2. Right-click or Control-click on the Accordance.wdgt file and choose "Show Package Contents"

 

3. Locate the file copypaste.scpt inside the /Scripts/ folder

 

4. Double click that file which will open it up in Applescript Editor

 

5. Find and select these 9 lines:

tell frontApp to tell menu bar 1
    if (exists menu item "Paste and Match Style" of menu "Edit") then
        click menu item "Paste and Match Style" of menu "Edit"
    else if (exists menu item "Paste" of menu "Edit") then
        click menu item "Paste" of menu "Edit"
    else
        tell application "System Events" to keystroke "v" using {command down}
    end if
end tell

6. Delete and replace them with

keystroke "v" using {command down}

7. Save and quit Applescript Editor. The paste-in option will now work in the Widget.

 

Note: if you'll only be using the widget to paste into an app that uses command+option+shift+v as the shortcut for "Paste and match style, you can make that happen by instead putting in the script:

keystroke "v" using {command down, shift down, option down}

  • Don Ruhl and circuitrider like this
Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#6 Don Ruhl

Don Ruhl

    Member

  • Active Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Grants Pass, Oregon
  • Accordance Version:10.x

Posted 12 November 2013 - 05:54 PM

Joe, 

 

I finally got around to trying your temporary solution until Accordance can fix the problem. Thanks, your work around proved successful! I rely upon the widget heavily, so this was a great relief to me! 


Don Ruhl
Church of Christ
220 NE Savage Street
Grants Pass, Oregon 97526-1310
541-476-3100
http://www.GrantsPas...rchofChrist.com
http://www.TheBibleMeditator.com
http://associate.com...aildevotionals/

#7 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 07 December 2013 - 04:22 PM

Joe,

 

Thank you for the detailed work around, your help is greatly appreciated.

 

I would like to see this remedied in future updates, I also use the widget extensively.


Edited by circuitrider, 06 January 2014 - 01:07 AM.

  • Don Ruhl likes this

#8 nikonaddict

nikonaddict

    Member

  • Active Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Zion, IL
  • Interests:Photographing the lands of the Bible
  • Accordance Version:11.x

Posted 12 December 2013 - 05:10 PM

I was wondering if someone is still working on the Wiget or if it has been abandoned? I use it over 100 times a week (at least) and don't want to upgrade my main computer to Mavericks if it means I lose the functionality of the Widget.


  • Don Ruhl and circuitrider like this

#9 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 06 January 2014 - 01:20 AM

Joe, 

 

Thanks again for posting the work around.

 

When I use it in Pages '09 it always pastes in Helvetica when I have the 'auto insert' box checked.  Is there a command line I can add so it will match the present formatting?  I can work around it by unchecking 'auto insert' and then utilizing the copy button and then pasting with match formatting hot-key stroke.  However, I would like to avoid that extra step if possible.

 

Thank you.



#10 Joe Weaks

Joe Weaks

    Platinum

  • Active Members
  • PipPipPipPipPip
  • 1,085 posts
  • Gender:Male
  • Location:Odessa, TX
  • Interests:I like things that are Orange, and possibly Blue.
  • Accordance Version:11.x

Posted 06 January 2014 - 06:01 PM

Joe, 

 

Thanks again for posting the work around.

 

When I use it in Pages '09 it always pastes in Helvetica when I have the 'auto insert' box checked.  Is there a command line I can add so it will match the present formatting?  …

 

I'm very glad the solution is working for you.

Yes, as I gave as an addendum in the previous instructions, you can do it easily if you'll only be using the auto paste in apps that use command+option+shift+v to paste and match style like Pages, Word and TextEdit:

Note: if you'll only be using the widget to paste into an app that uses command+option+shift+v as the shortcut for "Paste and match style, you can make that happen by instead putting in the script:

keystroke "v" using {command down, shift down, option down}

 

use that line instead of the keystroke "v" using {command down} line that you previously added. Let me know if it's confusing or is not working.

If you need to work in more than one app, it is even possible to change the code to say:

If front app is Pages, then use command option shift v

otherwise use just command v

etc.


Joe Weaks
The Macintosh Biblioblog

Sometimes I'm so helpful even I can't stand it.

#11 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 06 January 2014 - 07:11 PM

Joe,

 

I did indeed use:

 

keystroke "v" using {command down, shift down, option down}

 

I was still getting Helvetica.

 

Within Pages I looked at the Edit drop down menu and for some reason my shortcut key-stroke is "⌘V"  to paste and match style, so I changed the command line to read:

 

keystroke "v" using {option down, shift down, command down}

 

And it worked!  That made my day.

 

Thank you for responding and also for sharing your "script magic" with us.  Greatly appreciated.  



#12 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,048 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 08 January 2014 - 12:23 PM

1.6.7 of the Widget has been posted here:

 

http://www.accordanc...stallers#Widget

 

It fixes the ability to Auto Insert from the widget.  Auto Search still doesn't work in Mavericks and may never work, due to the new security restrictions.  But, that can be worked around without too much hassle.


  • Dan Francis likes this
Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#13 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 08 January 2014 - 02:02 PM

Joel,

 

When I downloaded the file I received this error

 

 

"Accordance.wdgt" can't be opened because it is from and unidentified developer.



#14 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,048 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 08 January 2014 - 02:12 PM

You'll need to go to System Preferences -> Security -> General and allow the widget.  You might have to set it to allow from 'Anywhere' to install the new version, then return it to your prior setting.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#15 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 08 January 2014 - 02:30 PM

Thanks Joel, that worked.

 

However, I had downloaded the file twice and now I get two instances of the widget when pressing the dashboard key!

 

I deleted all of the accordance widgets in Library/Widgets and still get two.

 

Thanks for the help.



#16 Joel Brown

Joel Brown

    Administrator

  • Admin
  • 3,048 posts
  • Gender:Male
  • Location:Houston, TX
  • Accordance Version:11.x
  • Platforms:Mac OS X, Windows

Posted 08 January 2014 - 02:33 PM

You can remove open instances of the widget by holding the Option key and mousing over the widget.  So, close one, but ensure the remaining one does report 1.6.7.


Joel Brown

By day: Consultant for Oaktree
By night: Freelance Trombonist and Private Instructor

#17 circuitrider

circuitrider

    Gold

  • Active Members
  • PipPipPipPip
  • 329 posts
  • Gender:Male
  • Accordance Version:11.x
  • Platforms:Mac OS X, iOS

Posted 08 January 2014 - 02:40 PM

Got it!

 

A your instructions and a re-start fixed things up.

 

Thank you very much.







Also tagged with one or more of these keywords: maveric, widget

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users